Universal Windows Platform

Welcome to the Windows Platform Developer (WPDev) Feedback site. This feedback forum provides the WPDev community with a channel for feedback on the following topics:

  • Windows developer platform (APIs, runtimes, and controls)
  • Dev Center (developer portal, back-end services, reporting/analytics and process)
  • Microsoft Store

Your suggestions will be reviewed by the Windows platform developer team, providing feedback to help with planning ideas and to better understand how developers are using the development platform.

What this forum is not intended to cover or capture:

  • Windows:
  • Documentation on docs.microsoft.com
    • Sign in to give documentation feedback via Github
  • Visual Studio / .NET

If you’re new to this whole UserVoice thing, we’d like to note two important things about this site: (a) List items (and item rankings) represent community interest in features, and does not represent an actual priority list for the product team; and (b) Suggestions made using this forum will be moderated if they do not actually represent a feature request.

How can we improve the Windows dev platform?

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Enable the Windows 10 Hyper-V Default Switch to work with Cisco AnyConnect

    The following Hyper-V networking Configuration breaks DNS name resolution on the Virtual Machine:
    1. Connecting the host to a non-corporate (remote) WiFi network.
    2. Connecting to the corporate network via Cisco AnyConnect on the host.
    3. Start a VM and connect it to the Default Switch (NAT)

    When a VM is connected to the default switch and the host is connected to the corporate network via Cisco AnyConnect, the VM looses the ability to resolve DNS addresses. The VM is able to ping both public addresses and corporate addresses; however, it is unable to resolve names on either the public…

    170 votes
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      14 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

      We’re investigating how to best handle VPN and add more configuration around VPN.

      Please:
      1) Upvote if this is important to you. That helps us prioritize.
      2) Let us know which VPN technology you’re using/care most about.
      3) Explain what behavior you’d like to see.

    • keyboard closes when changing inputbox in assigned access mode

      Up until the latest windows update, the virtual keyboard worked fine, but now (using my app with the most recent nuget packages) in assigned access mode (tablet mode) the keyboard closes when tapping a different inputbox on a xaml form.

      To get the keyboard to return, you have to tap it again, and this happens on every single box. It didn't do this before the latest update.

      I'm using a tablet with Win 10 Pro build 1709

      2 votes
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
      • [Bug] UWP SwipeControl: unexpected behaviour when FlowDirection is RTL

        Scenario:
        App language is English (FlowDirection: LTR)
        Swiping a SwipeControl item from the right to the left will reveal the options on the right (as if dragging the item to the left, revealing options behind it. EXPECTED)
        User changes the language to Arabic (FlowDirection: RTL)
        Expectation: User swipes from the left to the right to reveal the options on the left (as if dragging the item to the right to reveal options behind it)
        Currently: user swipes from the right to the left to reveal the options on the left (as if the item is moving in the opposite direction…

        3 votes
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
        • InvalidCastException in MediaComposition.GetThumbnailAsync() on VMs

          We use MediaComposition to generate thumbnails for mp4 video files. It's working great on physical machines. But on virtual machines we get a InvalidCastException. It's happening on multiple different virtualizers (Parallels, VirtualBox, ...).

          Here is a small testing UWP app:

          I've also posted the full exception there.

          1 vote
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
          • UWP StoreAppLicense TrialTimeRemaining gives wrong result after trial expired

            After a trial has expired the expiration date is set to:
            Month 12, Day 31, year 9999

            1 vote
            Sign in
            Check!
            (thinking…)
            Reset
            or sign in with
            • facebook
            • google
              Password icon
              Signed in as (Sign out)

              We’ll send you updates on this idea

              0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
            • Windows.Devices.Display.DisplayMonitor.FromIdAsync() fails with ERROR_FILE_NOT_FOUND exception

              The new API for Windows 1803 to create DisplayMonitor instance always fails with ERROR_FILE_NOT_FOUND exception. No sample code yet available in SDK.
              Tested on two Windows 10 systems with 17134.48. Tested in both c++ and c#.

              See console cpp/winrt sample code here:
              https://gist.github.com/jonitis/c4d35dd3a7ce8cf47d1f4cd5bf665f01

              c# fragment:

              string monitorSelector = DisplayMonitor.GetDeviceSelector();
              DeviceInformationCollection deviceInfoCollection = await DeviceInformation.FindAllAsync(monitorSelector);

              foreach (DeviceInformation deviceInfo in deviceInfoCollection)
              {
              string id = deviceInfo.Id;

              DisplayMonitor monitor = await DisplayMonitor.FromIdAsync(id);

              string dn = monitor.DisplayName;
              }

              1 vote
              Sign in
              Check!
              (thinking…)
              Reset
              or sign in with
              • facebook
              • google
                Password icon
                Signed in as (Sign out)

                We’ll send you updates on this idea

                0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
              • Changing DataContext modifies previously bound view model

                Using the fall creator's update version of UWP, it seems that when a data context is changed to a new view model, the previous view model is updated with null values. This is the same as if the DataContext is set to null before changing view models. It doesn't make sense why the bound values are updated when the DataContext is changed.

                2 votes
                Sign in
                Check!
                (thinking…)
                Reset
                or sign in with
                • facebook
                • google
                  Password icon
                  Signed in as (Sign out)

                  We’ll send you updates on this idea

                  9 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                • Microsoft-Windows-WMI-Activity

                  The Microsoft-Windows-WMI-Activity ETW provider has some updated events with new fields on WIndows 10 1803 (specifically event 11, but there may be other ones), but the version field in these events has not been updated. This makes working with these events a bit difficult, as you need to keep track of Windows versions for compatibility, instead of simply checking the version field of the event itself.

                  1 vote
                  Sign in
                  Check!
                  (thinking…)
                  Reset
                  or sign in with
                  • facebook
                  • google
                    Password icon
                    Signed in as (Sign out)

                    We’ll send you updates on this idea

                    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                  • Click/Tapped event can be invoked multiple times in a single instance and crashes application

                    Hello,
                    on Windows 10 UWP apps, if you rapidly click or unintentionally double-click on any control supporting click/tapped event, its associated Click event handler will execute for each. This can cause a lot of unintended side effects.
                    For example, if the Click event handler brings up a modal ContentDialog with the ShowAsync command, an additional click will cause the event handler to fire again before modal isolation occurs and create another ContentDialog, which causes an exception, if not handled will result in a crash of the application. In my opinion, developers should not have to do this to prevent multiple…

                    3 votes
                    Sign in
                    Check!
                    (thinking…)
                    Reset
                    or sign in with
                    • facebook
                    • google
                      Password icon
                      Signed in as (Sign out)

                      We’ll send you updates on this idea

                      0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                    • InputPane does not open when focus is shifted to next input element with InputPane opened in previous input element.

                      Unable to prevent auto close of InputPane which is creating issue due to a possible bug of InputPane in UWP with target version 16299 on Tablet.

                      If we have to move focus from one input to other and in this process of focusing next element if input pane was opened in first input and 2nd input element needs UpdateLayout for showing InputPane then InputPane for 2nd will not be opened on tap ( you have to tap input if you are getting focus through Tab button on InputPane, to open InputPane which is also a bug as by default it…

                      1 vote
                      Sign in
                      Check!
                      (thinking…)
                      Reset
                      or sign in with
                      • facebook
                      • google
                        Password icon
                        Signed in as (Sign out)

                        We’ll send you updates on this idea

                        0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                      • 'OperationCompleted' event not raised after 'Paste' operation

                        DataPackage.OperationCompleted is not raised (at least when pasting text).

                        This is contrary to the docs, and to expected behavior.

                        1 vote
                        Sign in
                        Check!
                        (thinking…)
                        Reset
                        or sign in with
                        • facebook
                        • google
                          Password icon
                          Signed in as (Sign out)

                          We’ll send you updates on this idea

                          0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                        • DataPackage.SetDataProvider doesn't delay-render text on the Clipboard

                          (It's does with Html, but not with Text.)

                          This is contrary to the docs, and to expected behavior. Sometimes we need this even with text.

                          1 vote
                          Sign in
                          Check!
                          (thinking…)
                          Reset
                          or sign in with
                          • facebook
                          • google
                            Password icon
                            Signed in as (Sign out)

                            We’ll send you updates on this idea

                            0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                          • BSOD 0xe6

                            1. Attach devices to another and ensure it full loading
                            2, Hot plug device to unit and idle about 1min
                            3. Hot unplug and wait about 30s
                            4. Re-plug again
                            5. Found BSOD(0xe6) occurred.FR:1/50

                            I have chick bug code 0xe6 is DRIVER_VERIFIER_DMA_VIOLATION.
                            I use driver verifier to see what happen, but when restart, where did I find my log file or result.And how to fix it .
                            From dump file. I can see it relative with USBXHCI.But I have no idea.

                            1 vote
                            Sign in
                            Check!
                            (thinking…)
                            Reset
                            or sign in with
                            • facebook
                            • google
                              Password icon
                              Signed in as (Sign out)

                              We’ll send you updates on this idea

                              0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                            • [Bug] Windows Explorer drag from screen 1 to 2

                              I have a Windows 10 notebook with a second screen. And I have a problem with windows explorer that it breaks every time when I try to move from one screen to another.

                              I just figured out what was the problem and I can work with it without any problem, but I want to post it to see if it can be fixed for another user.

                              How to emulate the bug
                              - Open windows explorer:
                              - resize the windows explorer window to something like 300px to 300px
                              - maximize the window
                              - Now with the mouse pointer, click on the…

                              1 vote
                              Sign in
                              Check!
                              (thinking…)
                              Reset
                              or sign in with
                              • facebook
                              • google
                                Password icon
                                Signed in as (Sign out)

                                We’ll send you updates on this idea

                                0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                              • ucrtbase bug: isalnum() is broken in RS4

                                What:
                                isalnum(-1) returns true for some codepages.

                                Code for reproducing:

                                #include <stdio.h>
                                #include <ctype.h>
                                #include <locale.h>
                                void main()
                                {
                                printf("before locale: %d\n", isalnum(-1));
                                setlocale(LC_ALL, "English_United States.1251");
                                printf("after locale: %d\n", isalnum(-1));
                                }

                                Compile using "cl test.cpp /MD" and run under RS4.

                                The output is:
                                before locale: 0
                                after locale: 258

                                Please fix.

                                1 vote
                                Sign in
                                Check!
                                (thinking…)
                                Reset
                                or sign in with
                                • facebook
                                • google
                                  Password icon
                                  Signed in as (Sign out)

                                  We’ll send you updates on this idea

                                  0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                • Give users the option to disable automatic application starts after restart

                                  The new fall creators update seems to have introduced a 'feature' where if a user reboots the system, any applications that were open (well, some at least, it seems as though to make this issue even more confusing, not all applications follow this convention) will automatically launch on reboot.

                                  Some users certainly will find this useful. Others may find this annoying.

                                  Sadly, if you're someone who finds this annoying, there's no option to disable this behavior.

                                  According to the singular post I was able to find on this new feature (https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_desktop/programs-autostart-after-boot-in-windows-10/09dd8d3e-7b36-45d1-9181-6587dd5d53ab?page=2&auth=1) there is no way to disable this.

                                  2 votes
                                  Sign in
                                  Check!
                                  (thinking…)
                                  Reset
                                  or sign in with
                                  • facebook
                                  • google
                                    Password icon
                                    Signed in as (Sign out)

                                    We’ll send you updates on this idea

                                    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                  • Microsoft's internet site does not work normally with IE

                                    The following page https://www.visualstudio.com/vs/preview/ does not work in IE. I cannot expand FAQ entries and so on. The page above also recommends me to set up the MS Edge. The MS Edge is incompatible with my LTSB system. See https://docs.microsoft.com/en-us/microsoft-edge/deploy/hardware-and-software-requirements .
                                    My idea is either to fix the Internet (I have problems not only with https://www.visualstudio.com/vs/preview/ but with some other sites too -- GitHub warns me to update too) or the MS LTSB systems (personally I am interested in MS Windows Server 2016).
                                    Thank you.

                                    1 vote
                                    Sign in
                                    Check!
                                    (thinking…)
                                    Reset
                                    or sign in with
                                    • facebook
                                    • google
                                      Password icon
                                      Signed in as (Sign out)

                                      We’ll send you updates on this idea

                                      0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                    • Header is missing in the given PDF when rendered using PdfDocument API

                                      In UWP, I extract the pages of a PDF using the method PdfDocument.GetPage(UInt32 pageIndex) and save the page as image to the local disk using PdfPage.RenderToStreamAsync(IRandomAccessStream outputStream). In the saved image the headers in the PDF pages are not rendered.

                                      The sample and the PDF document can be downloaded from the link below.

                                      https://1drv.ms/u/s!Am9BJQE8rPjqiMNHbwPO-P7lMwYX7A

                                      Best,

                                      Navaneetha Kannan

                                      1 vote
                                      Sign in
                                      Check!
                                      (thinking…)
                                      Reset
                                      or sign in with
                                      • facebook
                                      • google
                                        Password icon
                                        Signed in as (Sign out)

                                        We’ll send you updates on this idea

                                        0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                      • PasswordBox with NumericPin overrides InputScope for other controls

                                        We are experiencing an issue where the presence of a PasswordBox with a NumericPin InputScope overrides the InputScope of other controls on the page--until the PasswordBox has received focus.
                                        On a touch screen, this manifests every time a user reaches the first page in our UWP App that has a NumericPin-scoped PasswordBox.
                                        Repro steps:
                                        1) Create a new "Blank App" UWP project
                                        2) Add the XAML below to MainPage.xaml
                                        3) Build and run the app
                                        4) Before doing anything else, click the "Show touch keyboard" button in the notification tray such that the touch keyboard appears.
                                        5) See that the…

                                        6 votes
                                        Sign in
                                        Check!
                                        (thinking…)
                                        Reset
                                        or sign in with
                                        • facebook
                                        • google
                                          Password icon
                                          Signed in as (Sign out)

                                          We’ll send you updates on this idea

                                          1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                        • Binding something that is NOT an ICommand to an event gives an exception in the XAML compiler WCM9999: Object Reference not set

                                          In UWP XAML binding something that is NOT an ICommand to an event gives an exception in the XAML compiler WCM9999: Object Reference not set to an instance of an object.

                                          Take any XAML page add a button to it and bind it to any normal, as in not a command, on the view model. Compile the app and the Xaml compiler throws the exception.
                                          I would expect it to catch this an give a readable error message about an invalid binding, idealy the propertyname and the control type at least. Something that lets you investigate.

                                          1 vote
                                          Sign in
                                          Check!
                                          (thinking…)
                                          Reset
                                          or sign in with
                                          • facebook
                                          • google
                                            Password icon
                                            Signed in as (Sign out)

                                            We’ll send you updates on this idea

                                            0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                          ← Previous 1 3 4 5 6 7
                                          • Don't see your idea?

                                          Feedback and Knowledge Base