Universal Windows Platform

Welcome to the Windows Platform Developer (WPDev) Feedback site. This feedback forum provides the WPDev community with a channel for feedback on the following topics:

  • Windows developer platform (APIs, runtimes, and controls)
  • Dev Center (developer portal, back-end services, reporting/analytics and process)
  • Microsoft Store

Your suggestions will be reviewed by the Windows platform developer team, providing feedback to help with planning ideas and to better understand how developers are using the development platform.

What this forum is not intended to cover or capture:

  • Windows:
  • Documentation on docs.microsoft.com
    • Sign in to give documentation feedback via Github
  • Visual Studio / .NET

If you’re new to this whole UserVoice thing, we’d like to note two important things about this site: (a) List items (and item rankings) represent community interest in features, and does not represent an actual priority list for the product team; and (b) Suggestions made using this forum will be moderated if they do not actually represent a feature request.

How can we improve the Windows dev platform?

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Enable the Windows 10 Hyper-V Default Switch to work with Cisco AnyConnect

    The following Hyper-V networking Configuration breaks DNS name resolution on the Virtual Machine:
    1. Connecting the host to a non-corporate (remote) WiFi network.
    2. Connecting to the corporate network via Cisco AnyConnect on the host.
    3. Start a VM and connect it to the Default Switch (NAT)

    When a VM is connected to the default switch and the host is connected to the corporate network via Cisco AnyConnect, the VM looses the ability to resolve DNS addresses. The VM is able to ping both public addresses and corporate addresses; however, it is unable to resolve names on either the public…

    199 votes
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      19 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

      We’re investigating how to best handle VPN and add more configuration around VPN.

      Please:
      1) Upvote if this is important to you. That helps us prioritize.
      2) Let us know which VPN technology you’re using/care most about.
      3) Explain what behavior you’d like to see.

    • DatePicker date bug when system timezone changes

      There seems to be a bug in the DatePicker control that appears when the system TimeZone changes.

      This can be easily reproduced, start by creating a UWP app that has the DatePicker control, and a TextBlock below it, bind them both to a DateTimeOffset object that will contain the value of DateTime.Now.

      Reproduction steps:
      1) Start the app, controls show DateTime.Now
      2) Use TZUTIL in CMD to change Timezone to something that makes the date change (For instance, from UTC-12 to UTC+14)
      3) Update controls with DateTime.Now

      Expected: DatePicker shows DateTime.Now.
      Actual: DatePicker shows old day, when opened shows correct…

      5 votes
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
      • [UWP] Files created with DownloadsFolder.CreateFileAsync cannot be loaded with StorageFile.GetFileFromPathAsync

        Files created with DownloadsFolder.CreateFileAsync cannot be loaded by the full path name with StorageFile.GetFileFromPathAsync. This doesn't really make sense as the documentation states, "All apps can create files and folders in the Downloads folder and can access the files that they create". Attempting to do this results in the following error:

        Exception thrown: 'System.UnauthorizedAccessException' in System.Private.CoreLib.dll
        WinRT information: Cannot access the specified file or folder (C:\Users\{Username}\Downloads\{PackageName}_y356m3t891zm4!App\{FileName}.pdf). The item is not in a location that the application has access to (including application data folders, folders that are accessible via capabilities, and persisted items in the StorageApplicationPermissions lists). Verify that the file…

        3 votes
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
        • Compilation of {x:Bind} to a global / static ViewModel fails when using Mode OneWay or TwoWay

          Compilation fails with error CS1061 in MainPage.g.cs: "MainPage.MainPage_obj1_Bindings" does not contain a definition for "bindingsTracking" and no extension method "bindingsTracking" accepting a first argument of type "MainPage.MainPage_obj1_Bindings" could be found.

          This is the same error that was marked Completed here:

          https://wpdev.uservoice.com/forums/110705-universal-windows-platform/suggestions/19316077-compilation-of-x-bind-to-static-fields-fails-if

          4 votes
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            3 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
          • RadioButton navigation bug when using TabFocusNavigation=Once and XYFocusKeyboardNavigation=Enabled

            Arrow keys do not move between radio buttons if the containing StackPanel has TabFocusNavigation="Once". If the containing StackPanel has TabFocusNavigation="Local" (or is not set) then the arrow keys will not move back from an initial RadioButton to a preceding Button in the StackPanel.

            Like this:

            <StackPanel XYFocusKeyboardNavigation="Enabled" TabFocusNavigation="Once">
            <Button Content="B1"/>
            <Button Content="B2"/>
            <RadioButton Content="R1" />
            <RadioButton Content="R2" />
            <RadioButton Content="R3" GroupName="X" />
            <RadioButton Content="R4" GroupName="X" />
            <RadioButton Content="R5" />
            <Button Content="B3"/>
            </StackPanel>

            While this example includes Button as well as RadioButton, the problem is evident even if you only have RadioButton.

            With TabFocusNavigation="Once", navigation gets stuck at R1. Starting with…

            1 vote
            Sign in
            Check!
            (thinking…)
            Reset
            or sign in with
            • facebook
            • google
              Password icon
              Signed in as (Sign out)

              We’ll send you updates on this idea

              1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
            • Filter Manager and Unified Write Filter incompatibility

              When the Unified Write Filter is running on a volume, where an excluded folder of exactly 5 characters is present in the root of the drive, the FltParseFileNameInformation fails miserably. It parses the information by setting ->Volume.Length to ->Name.Length + 2, which must never happen.
              Additionally, FltQueryFileNameInformation and FltPerformSynchronousIo cannot function on the file object, representing the particular folder.
              The issue does not happen on subfolders and files, but only on the 5-character folder in the root of the protected drive, which is excluded.

              1 vote
              Sign in
              Check!
              (thinking…)
              Reset
              or sign in with
              • facebook
              • google
                Password icon
                Signed in as (Sign out)

                We’ll send you updates on this idea

                0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
              • WEBVTT timed texts bug in media element

                If first cues start/end time is in "mm:ss" format, and continues with format "h:mm:ss" - they will not be parsed and not showed in TimedMetadataTrack.Cues list.

                For example:

                59:53.230 --> 59:56.480
                It works.

                59:57.280 --> 1:00:00.990
                But it is not parsed

                1:00:01.740 --> 1:00:04.080
                Also not parsed

                Example vtt file link:
                https://smotret-anime.ru/translations/vtt/1781022

                1 vote
                Sign in
                Check!
                (thinking…)
                Reset
                or sign in with
                • facebook
                • google
                  Password icon
                  Signed in as (Sign out)

                  We’ll send you updates on this idea

                  1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                • Toggleswitch when tabbed to (on) crashes with Access Violation Exception

                  OS: Windows 10 Pro 1803 build 17134.191
                  Target Platform (min): Windows 10 1803

                  When pressing tab to jump between controls, app crashes when it reaches a Toggleswitch control.

                  Have to use "IsTabStop=False" as a workaround, but not a good solution as the toggleswitches are not usable for keyboard users.

                  1 vote
                  Sign in
                  Check!
                  (thinking…)
                  Reset
                  or sign in with
                  • facebook
                  • google
                    Password icon
                    Signed in as (Sign out)

                    We’ll send you updates on this idea

                    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                  • accessing Removable Storage with FileStream: ok in version 15063, not in 16299/17134

                    the following code:

                    string _path = @"D:\TMP\test0.solaltxt";
                    FileStream _pfs = null;
                    try
                    {
                    Debug.WriteLine($"_path(-)={_path}");
                    _pfs = new FileStream(_path, FileMode.Create, FileAccess.Write, FileShare.None, 4096, true); // <<<<<<<<<<<<<<<<<<< OK with 15063, NOT OK with 16299/17134
                    Debug.WriteLine($"_path={_path} _pfs={_pfs}");
                    }
                    catch (Exception E)
                    {
                    Debug.WriteLine($"_path={_path} Exception={E.Message}");
                    }
                    finally
                    {
                    Debug.WriteLine($"_path(+)={_path}");
                    _pfs?.Dispose();
                    }

                    where D: is a USB drive appearing in the Windows.Storage.KnownFolders.RemovableDevices.GetFoldersAsync list, Removable Storage and File Association / '.solaltxt' are correctly set in the manifest.

                    works ok in version 15063, but not with 16299/17134 anymore: any comment would be welcome ...

                    1 vote
                    Sign in
                    Check!
                    (thinking…)
                    Reset
                    or sign in with
                    • facebook
                    • google
                      Password icon
                      Signed in as (Sign out)

                      We’ll send you updates on this idea

                      0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                    • Unable to create UWP App store package targeting Windows 10 version anything above 15063 if <uap5:DriverDependency> is defined in a package

                      Unable to create UWP App store package targeting Windows 10 version anything above 15063 if <uap5:DriverDependency> is defined in a package manifest file.

                      Set up :
                      VS 2017 15.7.3
                      SDK Installed 17134, 16299 and 15063.
                      Windows OS build : RS5 preview build.

                      In package manifest file, The dependencies block is defined as
                      <Dependencies>
                      <TargetDeviceFamily Name="Windows.Universal" MinVersion="10.0.16299.0" MaxVersionTested="10.0.17134.0" />
                      <PackageDependency Name="Microsoft.VCLibs.140.00" MinVersion="14.0.25426.0" Publisher="CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US" />
                      <uap5:DriverDependency>
                      <uap5:DriverConstraint Name="DTS-dtsaudioprocessinghsa.inf" />
                      </uap5:DriverDependency>
                      </Dependencies>

                      The UWP App solution compilation is OK but when creating a store package, it results into error:

                      AppxManifest.xml : error APPX0501: Validation error. error C00CE014:…

                      1 vote
                      Sign in
                      Check!
                      (thinking…)
                      Reset
                      or sign in with
                      • facebook
                      • google
                        Password icon
                        Signed in as (Sign out)

                        We’ll send you updates on this idea

                        0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                      • ZIP64: comply with ISO-21320-1:2015

                        bug description
                        ============
                        using "send to compressed ZIP folder" with files > 4GB outputs non-ISO-21320-1:2015-conforming files, which results in errors in many unzip softwares including 'unzip' reference implementation from info-zip.org as well as 7zip, libarchive, libzip and others.

                        solution
                        ======
                        change 1 bit in ZIP64 files to better comply with ISO-21320-1:2015 and normative APPNOTES from PKWARE in order to interoperate with other unzip software.

                        'Total number of disks' shall be 1 - not 0.
                        referring to section 4.3.15 [Zip64 end of central directory locator] in https://www.pkware.com/documents/APPNOTE/APPNOTE-6.3.3.TXT

                        see also https://github.com/LuaDist/unzip/blob/master/process.c#L1277-L1280

                        1 vote
                        Sign in
                        Check!
                        (thinking…)
                        Reset
                        or sign in with
                        • facebook
                        • google
                          Password icon
                          Signed in as (Sign out)

                          We’ll send you updates on this idea

                          0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                        • Can't establish connection with FullTrustProcess

                          From the build 17711, Windows.ApplicationModel.AppService.AppServiceConnection.OpenAsync() consistently returns 'Unknown Error'. I've tried this sample but not a luck.

                          https://github.com/Microsoft/DesktopBridgeToUWP-Samples/tree/master/Samples/AppServiceBridgeSample/cs

                          The unknown error also happens on build 17713 and I'm curious is this just a bug or will this feature stop on future windows release?

                          1 vote
                          Sign in
                          Check!
                          (thinking…)
                          Reset
                          or sign in with
                          • facebook
                          • google
                            Password icon
                            Signed in as (Sign out)

                            We’ll send you updates on this idea

                            0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                          • Setting IsZoomedInViewActive to False on a SemanticZoom hooks it to the BackRequested event.

                            However, if you set it to true, the SemanticZoom doesn't hook to the BackRequested event. This violates developer expectations. Since the SemanticZoom is subscribed to the BackRequested event, if I navigate to another page and press the back button, the BackRequested event is not called on my navigated page, since it is handled by the SemanticZoom in the previous page, even if page caching is disabled for the Frame. The SemanticZoom is kept alive because it is referenced by the SystemNavigationManager.

                            1 vote
                            Sign in
                            Check!
                            (thinking…)
                            Reset
                            or sign in with
                            • facebook
                            • google
                              Password icon
                              Signed in as (Sign out)

                              We’ll send you updates on this idea

                              1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                            • DNS-SD registration does not respond to queries with class "ANY"

                              A DNS-SD service registration does not respond to mDNS queries having a class of "ANY", but only responds to queries having a class of "IN".

                              Example code which registers a service using Windows' DNS-SD APIs:

                              ```
                              var service = new DnssdServiceInstance(...);
                              using (var socket = new StreamSocketListener())
                              {
                              var registration = await service.RegisterStreamSocketListenerAsync(socket);
                              // Do stuff now that the service is registered.
                              }
                              ```

                              You can use Wireshark to inspect packets and see that queries having a class of "ANY" will be answered by a DNS-SD registration from Bonjour but will not be answered by the above DNS-SD registration.

                              1 vote
                              Sign in
                              Check!
                              (thinking…)
                              Reset
                              or sign in with
                              • facebook
                              • google
                                Password icon
                                Signed in as (Sign out)

                                We’ll send you updates on this idea

                                0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                              • keyboard closes when changing inputbox in assigned access mode

                                Up until the latest windows update, the virtual keyboard worked fine, but now (using my app with the most recent nuget packages) in assigned access mode (tablet mode) the keyboard closes when tapping a different inputbox on a xaml form.

                                To get the keyboard to return, you have to tap it again, and this happens on every single box. It didn't do this before the latest update.

                                I'm using a tablet with Win 10 Pro build 1709

                                2 votes
                                Sign in
                                Check!
                                (thinking…)
                                Reset
                                or sign in with
                                • facebook
                                • google
                                  Password icon
                                  Signed in as (Sign out)

                                  We’ll send you updates on this idea

                                  1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                • SerialDevice can't receive data in some cases

                                  Windows.Devices.SerialCommunication.SerialDevice can't receive data in some cases.

                                  To reproduice:
                                  1) Take sample from here: https://github.com/Microsoft/Windows-iotcore-samples/tree/develop/Samples/SerialUART/CS

                                  2) In MainPage.xaml.cs change line 97 from serialPort.BaudRate = 9600; to serialPort.BaudRate = 115200;

                                  3) Comment lines from 105 to 108, where serial device settins read. This should be commented:
                                  /*txt += serialDevice.BaudRate + "-";
                                  txt += serialDevice.DataBits + "-";
                                  txt += serialDevice.Parity.ToString() + "-";
                                  txt += serialDevice.StopBits;*/

                                  4) Run application and set breakpoint ReadAsync method after line
                                  if (bytesRead > 0)

                                  5) Connect to port and try to send data to it

                                  6) You will see that "await loadAsyncTask" never ends...

                                  2 votes
                                  Sign in
                                  Check!
                                  (thinking…)
                                  Reset
                                  or sign in with
                                  • facebook
                                  • google
                                    Password icon
                                    Signed in as (Sign out)

                                    We’ll send you updates on this idea

                                    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                  • [Bug] UWP SwipeControl: unexpected behaviour when FlowDirection is RTL

                                    Scenario:
                                    App language is English (FlowDirection: LTR)
                                    Swiping a SwipeControl item from the right to the left will reveal the options on the right (as if dragging the item to the left, revealing options behind it. EXPECTED)
                                    User changes the language to Arabic (FlowDirection: RTL)
                                    Expectation: User swipes from the left to the right to reveal the options on the left (as if dragging the item to the right to reveal options behind it)
                                    Currently: user swipes from the right to the left to reveal the options on the left (as if the item is moving in the opposite direction…

                                    3 votes
                                    Sign in
                                    Check!
                                    (thinking…)
                                    Reset
                                    or sign in with
                                    • facebook
                                    • google
                                      Password icon
                                      Signed in as (Sign out)

                                      We’ll send you updates on this idea

                                      0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                    • All Windows 10 verisons include a one keychain( Bluetooth chip inserted in a keychain for Dynamic Lock to pair)

                                      one keychain( Bluetooth chip inserted in a keychain for Dynamic Lock to pair) included with software purchase and the option to purchase multiple key-chains for each user. With this option, feedback will provide a solution for pairing with device "security problem".

                                      1 vote
                                      Sign in
                                      Check!
                                      (thinking…)
                                      Reset
                                      or sign in with
                                      • facebook
                                      • google
                                        Password icon
                                        Signed in as (Sign out)

                                        We’ll send you updates on this idea

                                        0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                      • SwitchAsync() chrashed with new version 17134

                                        with new Version 17134 there are problems with function SwitchAsync() and friends.

                                        On IOT devices like RASPBERRY or i-PAN M7 after call of SwitchAsync() you will get black or blue screen and devices reboots.

                                        You can easy check failure with demo application MultipleViews from Windows-universal-samples-master.

                                        Press button "Show selected view as standalone" and app is chrashing.

                                        What is the problem? How can I solve it.
                                        Thanks

                                        1 vote
                                        Sign in
                                        Check!
                                        (thinking…)
                                        Reset
                                        or sign in with
                                        • facebook
                                        • google
                                          Password icon
                                          Signed in as (Sign out)

                                          We’ll send you updates on this idea

                                          0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                        • Stablizied Window 10

                                          Stablizing OS. Your recent upgrade keep killing dwm.exe, which it's caused display driver to died. WIN+SHIFT+CTRL+B key doesn't work. Forcing us to restart. Most of us don't give a care about Apple features, we just want controllable situation and not wasting our time, trying to delete virus that you recently given to us.

                                          Please, with any humanity in you! Just stabilizing WIndows 10, removing features if you must!

                                          1 vote
                                          Sign in
                                          Check!
                                          (thinking…)
                                          Reset
                                          or sign in with
                                          • facebook
                                          • google
                                            Password icon
                                            Signed in as (Sign out)

                                            We’ll send you updates on this idea

                                            0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
                                          ← Previous 1 3 4 5 6 7
                                          • Don't see your idea?

                                          Feedback and Knowledge Base