How can we improve the Windows dev platform?

LoggingChannel not showing string message content in ETW payload around 15043

It seems that since around 15043, when showing LoggingChannel.LogMessage() calls, the string message portion is blank in device portal (shows stringmessage:,). Same code on machine with anniversary update, portal shows the string message in payload.
capturing events with xperf shows the message in EventData as expected, so I know it's logging correctly. Something seems to have changed with loggingchannel, possibly default manifest code that handles the string message has changed around 15043?
FWIW, preview versions of windows post anniversary update were showing the message correctly.

7 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Kevin Haney shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    in preview  ·  Hirsch Singhal responded  · 

    We’ve found a fix and it will be going out in an upcoming Windows Insiders Flight. We’ll be looking for feedback on the new output to determine if this should be backported to the Creators Update release.

    Thank you,
    Hirsch

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        I have now tried this with Insider Preview Build 16193 (Windows10_InsiderPreview_IoTCore_RPi_ARM32_en-us_16193) and it is working.

        Logging from UWP on an RPI3

        Sample code:

        string s = string.Format("{0} > Sending message: {1}", DateTime.Now, messageString);
        LoggingChannel lc = new LoggingChannel("my provider", null, new Guid("4bd2826e-54a1-4ba9-bf63-92b73ea1ac4a"));
        lc.LogMessage(s);

      • Marco van Kimmenade commented  ·   ·  Flag as inappropriate

        Is this only a bug with the LoggingChannel?
        I'm using EventSource directly and in the output the Provider, Task and Payload are all empty.

      Feedback and Knowledge Base