$ | >

Enable network connection enumeration

ifconfig, ip, etc. doesn't currently work and /proc/net/dev doesn't exist in Bash on Windows 10 Anniversary Update or Insider builds.

This issue is being tracked in GitHub and a fix is being investigated: https://github.com/Microsoft/BashOnWindows/issues/908

Example scenario:
Running a hyper-v virtual machine win10pro with bash, network issues

user@WIN10PRO64-02:/$ sudo /sbin/ifconfig
Warning: cannot open /proc/net/dev (No such file or directory). Limited output.

/etc/resolve.conf has a dns server configured correctly.

Network does work and apt-get works,
but no 'ifconfig' and programs cannot call out to 'eth0'

Ubuntu is up to date as of this post.
apt-get update & apt-get upgrade both work

How do I get the ifconfig to work in a VM
(also added opendns IPs into windows network dns settings.)

Thanks

1,381 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Rob SharkeyRob Sharkey shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    Thank you all for your feedback and patience. Marking this item complete since we just delivered ifconfig and network connection enumeration support in Windows 10 Insider build 14965.

    Please read the post below:

    https://blogs.msdn.microsoft.com/commandline/2016/11/10/ifconfig-and-network-connection-enumeration-support-in-windows-10-insider-build-14965/

    133 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Maurice AmptMaurice Ampt commented  ·   ·  Flag as inappropriate

        Is there any information on when this might appear in the regular Windows 10 builds?
        I tried to find any information on the system used for Insider builds vs mainstream builds, but wasn't successful...

      • Rich TurnerAdminRich Turner (Sr. Program Manager, Windows Console & WSL, Windows Developer) commented  ·   ·  Flag as inappropriate

        "Should be working" True. However, there are some key differences between how Linux and Windows networking stacks line-up and we have some engineering left to do, to allow us to offer the correct services and capabilities on both sides to enable a smooth set of networking operations between Windows and Linux.

        Most of the tools you list work fine in Insider/Creators Update builds, except traceroute and nmap, but we'll be working on fixing these issues in the next release.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Basic networking command should be working. That is why lots of people use the bash shell. My own usage is: ifconfig, dig, ping, traceroute, nmap, telnet, ssh, ftp, scp, script. Of course the rest of the bash tools like sed, awk, sort, grep, cron, perl, python, ansible, make, tar, gzip. This is what I use day to day. By having these tools I would not need any other platform.

      • John R.John R. commented  ·   ·  Flag as inappropriate

        I am so very happy to see the bash console in Windows! But the ability to use iptables to set a firewall would make it much more helpful. Also, students find it hard to learn bash in Windows unless the network functions work properly, as in the textbooks...

        Please add this functionality! It will keep more IT folks using Windows in whole or part.

      • Anonymous commented  ·   ·  Flag as inappropriate

        ifconfig does work but ip doesn't.
        When I run "ip a" I get this error:
        Cannot send dump request: Invalid argument
        I tried both on normal account and root both on Bash ran as normal user and with administrative privileges.

        So I'd reopen the idea until fixed.

      • Anonymous commented  ·   ·  Flag as inappropriate

        It is not possible to command OpenStack with Ansible because of this issue, as Shade module cannot work due to missing networking stuff on WSL.

      • Andy KellyAndy Kelly commented  ·   ·  Flag as inappropriate

        Networking breaks when connecting to a VPN on host device also. Makes it useless when trying to run ansible against AWS as VPN is required.

      • FeddFedd commented  ·   ·  Flag as inappropriate

        Bash without networking is just an Ubuntu icon on my windows desktop (looks nice, yes). In my opinion this issue needs to be a priority on WSL devel.

        By now i come back to my Linux VM

      • BrettBrett commented  ·   ·  Flag as inappropriate

        Before this issue was merged with other duplicate issues, one of them was marked as "Working on it". This is now marked "It's planned". That shounds like a step back. Can we get an update on the roadmap for this feature since it's a major blocker for any real-world web dev work?

      ← Previous 1 3 4 5 6 7

      Feedback and Knowledge Base