$ | >

ssh-agent not persisting added identities

title stolen from superuser forum, this is a deal breaker as an admin, I need the ssh-agent to "just work" every time I open WSL. right now I have to run commands to add identities every time I reboot or restart bash. I just find myself going back to putty to log into hosts so I don't have to go through the process of | eval $(ssh-agent) -> ssh-add <username>.pem blah blah

9 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Jed Boulton shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    1 comment

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Jed Boulton commented  ·   ·  Flag as inappropriate

        yes I'm aware of the workarounds, I've done the workarounds, still it would be nice if this worked OOB

      Feedback and Knowledge Base