$ | >

Supporting uclust on qiime1 for microbiome analysis

Please support uclust on qiime1 due to performing microbiome analysis from raw DNA sequencing data.
I tried to install qiime1 with miniconda3 on WSL (Windows10 Home, version 1709, OS build 16299.192, 64 bit operating system) recently and last year.
But it resulted in error like Mr. Schenck (https://groups.google.com/forum/#!topic/qiime-forum/uY1rD38CFPM).

The error was that Uclust isn't supported.
I think that WSL can't recognize uclust version because WSL couldn't answer uclust version at that time when I asked it.
I would be grateful if you support uclust on qiime1 on miniconda3 on WSL.

Actual flow
1. Install qiime1 according to QIIME1 installation method for miniconda3 on Linux on QIIME1 HP(http://qiime.org/install/install.html).
($ conda create -n qiime1 python=2.7 qiime matplotlib=1.4.3 mock nose -c bioconda)
2.In activated qiime1 environment on miniconda3, test command ($ print_qiime_config.py -t) resulted in error of no libsm6.
3. In activated qiime1 environment on miniconda3, install libsm6.
($ sudo apt-get install libsm6 libxrender1 libfontconfig1)
4. In activated qiime1 environment on miniconda3, test command ($ print_qiime_config.py -t) resulted in error of unsupported uclust.

~$ print_qiime_config.py -t
System information
==================
Platform: linux2
Python version: 2.7.14 |Anaconda, Inc.| (default, Dec 7 2017, 17:05:42) [GCC 7.2.0]
Python executable: /home/user/miniconda3/envs/qiime1/bin/python

QIIME default reference information
===================================
For details on what files are used as QIIME's default references, see here:
https://github.com/biocore/qiime-default-reference/releases/tag/0.1.3

Dependency versions
===================
QIIME library version: 1.9.1
QIIME script version: 1.9.1
qiime-default-reference version: 0.1.3
NumPy version: 1.13.3
SciPy version: 1.0.0
pandas version: 0.21.1
matplotlib version: 1.4.3
biom-format version: 2.1.6
h5py version: 2.7.1 (HDF5 version: 1.10.1)
qcli version: 0.1.1
pyqi version: 0.3.2
scikit-bio version: 0.2.3
PyNAST version: 1.2.2
Emperor version: 0.9.51
burrito version: 0.9.1
burrito-fillings version: 0.1.1
sortmerna version: SortMeRNA version 2.0, 29/11/2014
sumaclust version: SUMACLUST Version 1.0.00
swarm version: Swarm 1.2.19 [Mar 1 2016 23:41:10]
gdata: Installed.

QIIME config values
===================
For definitions of these settings and to learn how to configure QIIME, see here:
http://qiime.org/install/qiime_config.html
http://qiime.org/tutorials/parallel_qiime.html

blastmat_dir: None
pick_otus_reference_seqs_fp: /home/user/miniconda3/envs/qiime1/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/rep_set/97_otus.fasta
sc_queue: all.q
topiaryexplorer_project_dir: None
pynast_template_alignment_fp: /home/user/miniconda3/envs/qiime1/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/rep_set_aligned/85_otus.pynast.fasta
cluster_jobs_fp: start_parallel_jobs.py
pynast_template_alignment_blastdb: None
assign_taxonomy_reference_seqs_fp: /home/user/miniconda3/envs/qiime1/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/rep_set/97_otus.fasta
torque_queue: friendlyq
jobs_to_start: 1
slurm_time: None
denoiser_min_per_core: 50
assign_taxonomy_id_to_taxonomy_fp: /home/user/miniconda3/envs/qiime1/lib/python2.7/site-packages/qiime_default_reference/gg_13_8_otus/taxonomy/97_otu_taxonomy.txt
temp_dir: /tmp/
slurm_memory: None
slurm_queue: None
blastall_fp: blastall
seconds_to_sleep: 1

QIIME base install test results
===============================
........F
======================================================================
FAIL: test_uclust_supported_version (__main__.QIIMEDependencyBase)
uclust is in path and version is supported
----------------------------------------------------------------------
Traceback (most recent call last):
File "/home/user/miniconda3/envs/qiime1/lib/python2.7/site-packages/qiime-1.9.1-py2.7.egg-info/scripts/print_qiime_config.py", line 336, in test_uclust_supported_version
% ('.'.join(map(str, acceptable_version)), version_string))
AssertionError: Unsupported uclust version. 1.2.22 is required, but running Segmentation fault (core dumped)
.

----------------------------------------------------------------------
Ran 9 tests in 0.136s

FAILED (failures=1)

3 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    camel shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • xiaoguai945yeah commented  ·   ·  Flag as inappropriate

        Same error occurred on my computer.
        I add some more information here.

        (qiime1) yugao@ThinkPad-YuGAO:~$ which uclust
        /home/yugao/miniconda3/envs/qiime1/bin/uclust
        (qiime1) yugao@ThinkPad-YuGAO:~$ uclust
        Segmentation fault (core dumped)

      Feedback and Knowledge Base